Forum Indipendente Biciclette Elettriche, Pieghevoli e Utility

Forum Indipendente Biciclette Elettriche, Pieghevoli e Utility
[ Home | Registrati | Discussioni Attive | Discussioni Recenti | Segnalibro | Msg privati | Sondaggi Attivi | Utenti | Album Fotografico | Download | Links | FAQ |Ricerca Avanzata | le biciclette provate da noi ] mago job
Ultime novità: * è cambiata la denominazione del forum, leggere qui le motivazioni

* per evitare lo spam, l'iscrizione attende l'approvazione degli Amministratori, un po' di pazienza per favore

attenzione che la mail automatica di conferma iscrizione non sempre funziona, provare ad accedere lo stesso o scrivere in amministrazione

* per comunicazioni scrivere a postmaster@jobike.it o contattare uno degli amministratori (elle, job, pixbuster)

* registro bici rubate

* qui tutti i modelli testati da noi a confronto

 Tutti i Forum
 Discussioni
 Kit e fai da te
 TSDZ2 modifiche e documentazione varia

Nota: Devi essere registrato per poter inserire un messaggio.
Per registrarti, clicca qui. La Registrazione è semplice e gratuita!

Larghezza finestra:
Nome Utente:
Password:
Modo:
Formato: GrassettoCorsivoSottolineatoBarrato Aggiungi Spoiler Allinea a  SinistraCentraAllinea a Destra Riga Orizzontale Inserisci linkInserisci EmailInserisci FlashInserisci Immagine Inserisci CodiceInserisci CitazioneInserisci Lista Insert YouTube
   
Icona Messaggio:              
             
Messaggio:

  * Il codice HTML è OFF
* Il Codice Forum è ON

Faccine
Felice [:)] Davvero Felice [:D] Caldo [8D] Imbarazzato [:I]
Goloso [:P] Diavoletto [):] Occhiolino [;)] Clown [:o)]
Occhio Nero [B)] Palla Otto [8] Infelice [:(] Compiaciuto [8)]
Scioccato [:0] Arrabbiato [:(!] Morto [xx(] Assonnato [|)]
Bacio [:X] Approvazione [^] Disapprovazione [V] Domanda [?]
Seleziona altre faccine

   Allega file
  Clicca qui per inserire la tua firma nel messaggio.
Clicca qui per sottoscrivere questa Discussione.
   

V I S U A L I Z Z A    D I S C U S S I O N E
Mauri78 Inserito il - 06/07/2018 : 09:29:56
Ciao ragazzi, cercando in rete un pò di informazioni riguardanti il TSDZ2 mi sono imbattoto in questa pagina molto interessante:

https://opensourceebikefirmware.bitbucket.io/kunteng_lcd3/TSDZ2_configure_battery_voltage_and_motor_current.html

In pratica qualcuno ha scoperto che le centraline dei tsdz2 sono tutte uguali! 36V, 48V, varie potenze, con/senza acceleratore l'HW è lo stesso, cambia solo la configurazione della eeprom interna al micro.
Questa eeprom si può riprogrammare molto facilmente connettendosi sul cavo che va al sensore di velocità tramite un'interfaccina molto economica.
Inoltre esiste un firmware modificato per usare il display KT-LCD3 con il tsdz2 in modo da avere le seguenti feature:

- 5 assist levels (1 extra level)
- battery voltage (volts)
- motor electric power (watts)
- rider human power measured on pedals (watts)
- motor/battery current (amps)
- trip total in Watts/hour
- rider force on the pedals (Nm)
- pedals cadence (RPM)
- brakes state

E' tutto spiegato qui:
https://opensourceebikefirmware.bitbucket.io/kunteng_lcd3/LCD3_on_TSDZ2.html

Se a qualcuno dovesse servire qui trovate vari manuali riguardanti il motore, tra cui anche una sorta di manuale di officina ;-)

https://opensourceebikefirmware.bitbucket.io/development_tsdz2/

Spero che le informazioni linkate possano essere di aiuto per qualcuno, io le ho trovate molto interessanti.

Maurizio
50   U L T I M E    R I S P O S T E    (in alto le più recenti)
Chaussy Inserito il - 01/06/2020 : 21:41:35
Allora flashato al volo per provare, la prima cosa che si sente a differenza del firmware originale è molto più lineare non so bene come spiegarmi eroga insieme a te è più pronto mentre prima ogni tanto mi sembrava di usare una mtb muscolare.In salita non mi sembra che sia cambiato più di tanto ma ho fatto una prova veloce nemmeno di un km.
Il display mentre indicava la velocità ogni tanto si impallava poi si rimetteva a funzionare.
Questa sera mi leggo bene il manuale.
bik3r Inserito il - 01/06/2020 : 21:37:43

La scorsa settimana mi è arrivato l'ultimo modello ebike dell'Atala con batteria integrata con motore AM80 e devo ammettere che in salita spinge di più del TSDZ2, vedremo dopo la mod.
Grazie per la pazienza


Il motore AM80 spinge di più perchè assiste già da cadenze basse e ha un allungo eccezionale, il tsdz2 migliora con il firmware open, ma il sensore di sforzo più economico non è così sensibile come quello AM80.
Chaussy Inserito il - 01/06/2020 : 20:43:07
mbrusa ha scritto:

Chaussy ha scritto:

Risolto!
Qualcuno mi darebbe una mano a cosa inserire nel configuratore per i parametri della batteria.Da dove posso capire se ho un motore 36v o 48.
La batteria è la seguente:
https://www.amazon.it/Pswpower-batteria-bicicletta-elettrica-ciclista/dp/B07BD3P4DX

Grazie

Chaussy, se la batteria è quella del link a 36 Volt, anche il motore sarà 36 Volt. Avrai un riferimento di quando l'hai ordinato...
Con questi dati di motore, batteria e display VLCD5, puoi lasciare i valori di default, devi controllare solo il diametro della ruota.


Vado a Flashare, ti chiedo scusa sono totalmente nabbo in queste cose, mi piace smanettare capisco anche abbastanza di informatica ma il mondo delle ebike lo sto scoprendo poco a poco.La scorsa settimana mi è arrivato l'ultimo modello ebike dell'Atala con batteria integrata con motore AM80 e devo ammettere che in salita spinge di più del TSDZ2, vedremo dopo la mod.
Grazie per la pazienza
mbrusa Inserito il - 01/06/2020 : 20:15:47
Chaussy ha scritto:

Risolto!
Qualcuno mi darebbe una mano a cosa inserire nel configuratore per i parametri della batteria.Da dove posso capire se ho un motore 36v o 48.
La batteria è la seguente:
https://www.amazon.it/Pswpower-batteria-bicicletta-elettrica-ciclista/dp/B07BD3P4DX

Grazie

Chaussy, se la batteria è quella del link a 36 Volt, anche il motore sarà 36 Volt. Avrai un riferimento di quando l'hai ordinato...
Con questi dati di motore, batteria e display VLCD5, puoi lasciare i valori di default, devi controllare solo il diametro della ruota.
Chaussy Inserito il - 01/06/2020 : 18:28:43
Risolto!
Qualcuno mi darebbe una mano a cosa inserire nel configuratore per i parametri della batteria.Da dove posso capire se ho un motore 36v o 48.
La batteria è la seguente:
https://www.amazon.it/Pswpower-batteria-bicicletta-elettrica-ciclista/dp/B07BD3P4DX

Grazie
Chaussy Inserito il - 01/06/2020 : 16:33:08
mbrusa ha scritto:

Puoi scaricarlo dal link in firma.
Se non lo hai già fatto una lettura dei manuali.
Poi apri il configuratore (JavaConfigurator.jar)
Controlla e modifica almeno i parametri di base, sono quelli evidenziati in rosso.
Poi click su "Compile & Flash".



Grazie per avermi risposto, mi sa che mi sono perso in un bicchier d'acqua, la fretta mi frega,faccio come consigliato e poi dopo aver letto al max provo a chiedere delucidazioni.
Scusate ho scaricato il configuratore, ma cliccandoci sopra non succede niente, ho anche provato ad aggiornare java.Consigli?
mbrusa Inserito il - 01/06/2020 : 16:20:31
Puoi scaricarlo dal link in firma.
Se non lo hai già fatto, una lettura dei manuali aiuta.
Poi apri il configuratore (JavaConfigurator.jar)
Controlla e modifica almeno i parametri di base, sono quelli evidenziati in rosso.
Poi click su "Compile & Flash".
Chaussy Inserito il - 01/06/2020 : 16:06:16
Ciao a tutti, oggi ho effettuato il backup del firmware del motore, qualcuno gentilmente mi passerebbe l'ultimo firmware di mbrusa compilato per lcd5?
Grazie.
zappan Inserito il - 29/05/2020 : 21:50:17
Ciao a tutti, ho installato l'interfaccia Bluetooth di Mspider65 che dire è spettacolare si è aperto un mondo
http://www.jobike.it/forum/topic.asp?TOPIC_ID=78456
Ancora grazie a Massimo per il progetto e per averlo reso pubblico e di possibile realizzazione.
A questo punto il brutto anatroccolo (TSDZ2) è davvero il riferimento per i Kit motori e non solo
Trevy Inserito il - 28/05/2020 : 10:45:16
Grazie, per la conferma, così era sul manuale ma per qualche ragione a me sconosciuta non mi sembrava logico.
Sto apprezzando la incredibile linearità di erogazione anche a piccolissime potenze, anche spingendo, una vera bestia. Ancora grazie a tutti per l'incredibile lavoro.
mbrusa Inserito il - 28/05/2020 : 07:35:13
Si Trevy, "Battery voltage calibration" serve solo per correggere il valore di tensione visualizzato a display, non ha nessun'altra funzione.
Il parametro per il reset della batteria al 99,9% è "Reset soc percentage", di default 4,05 Volt, per evitare reset indesiderati dopo giri brevi devi aumentarlo.
Nella sezione "Battery cells settings" del configuratore trovi i parametri per la calibrazione delle tacche, compreso "Cell voltage empty" per la batteria scarica.
A batteria scarica, il parametro "Battery voltage cut-off" serve per limitare la corrente del motore, fino a zero.
Non è previsto nessun spegnimento del controller, se succede, probabilmente interviene il BMS della batteria.
Trevy Inserito il - 27/05/2020 : 21:34:59
@mbrusa
perdona la domanda, più una conferma.
ACTUAL_BATTERY_VOLTAGE_PERCENT incide solo sui valori a display?
mi sembra che la taratura del voltmetro non lavora ne sull'indicatore a barre ne sul reset 99.9%

ovvero pur abbassandolo ho problemi di reset per poca strada percorsa dopo la carica sia problemi di spegnimento del il controller a 1 tacca.

chiedo anche conferma se il controller visualizza lo zero tacche prima di finire la batteria.
buranel Inserito il - 27/05/2020 : 12:50:45

Ciao buranel, grazie per le prove, ora posso escludere che il problema sia legato a fix overrun.
Purtroppo questo difetto della latenza io non riesco a riprodurlo, anche questa mattina ho provato in diverse condizioni e quando riprendo l'assistenza è immediata, confermato anche dal wattmetro.
L' unica cosa che ho notato è che abilitando "Experimental high cadence mode" la ripresa è un pò più lenta.
Tu hai motore e batteria a 48 Volt?

Ciao Mbrusa si ho motore e batteria a 48
potresti te fare una prova: Experimental high cadence mode attivo il start up assistance threshold lo tieni bassino 10/15 e porti a zero torque ADC offset e a zero anche il motor ramp down.
prova in sia in power emtb e torque poi mi dici
Non vorrei dire castronerie perche non so come funziona la cosa...ma ho come l'impressione che x la ripartenza tenga conto solo della lettura del torque e non del pas.
mbrusa Inserito il - 27/05/2020 : 11:34:12
buranel ha scritto:

Ciao Mbrusa ho fatto una prova veloce con la 20beta1A senza fix overrun si comporta allo stesso modo c'e latenza quando si smette di pedalare/si riparte
Ho provato solo in Emtb e in Torque e confermo che in Torque c'e meno latenza anche con questa versione.
Ho usato gli stessi parametri di configurazione anche assist whitout pedal ma è molto meno reattiva in partenza da fermo probabilmente perche manca il parametro ADC range

Ciao buranel, grazie per le prove, ora posso escludere che il problema sia legato a fix overrun.
Purtroppo questo difetto della latenza io non riesco a riprodurlo, anche questa mattina ho provato in diverse condizioni e quando riprendo l'assistenza è immediata, confermato anche dal wattmetro.
L' unica cosa che ho notato è che abilitando "Experimental high cadence mode" la ripresa è un pò più lenta.
Tu hai motore e batteria a 48 Volt?
mbrusa Inserito il - 27/05/2020 : 11:15:03
thineight ha scritto:
Evidentemente mi sono dimenticato di archiviare quest'ultima e quindi non ricordo chi l'ha sviluppata e se è effettivamente l'ultima.
Chiedo allora a mbrusa se... ne rivendica la paternità.

zappan ha scritto:
Ciao, hai ragione ho controllato il 5 maggio nè ha rilasciata un'altra:
https://endless-sphere.com/forums/download/file.php?id=272811
spero che sia davvero l'ultima

Ciao thineight, che confusione...
Confermo che quella del 05/05 linkata da zappan è l'ultima ed è la stessa postata qua il 16/05 a pagina 70.
http://www.jobike.it/Public/data/mbrusa/202051694447_TSDZ2-v0.20.1-update_fix_overrun-LCD3_version.zip
zappan Inserito il - 27/05/2020 : 08:18:31
thineight ha scritto:

zappan ha scritto:

thineight ha scritto:

Scusate, mi sono un attimo perso su quale sia l'ultima versione per LCD3. La trovo su github o devo scorrere indietro questo thread per recuperare l'hex?

Grazie e buona serata.


Ciao, io l'ho scaricata da endeless e credo sia l'ultima: https://endless-sphere.com/forums/download/file.php?id=269437 , qui l'ho vista ma su github non credo che ci sia.

Grazie zappan, ma credo che questa che dici del 30 marzo non sia l'ultima.

Nelle mie cartelle dedicate al motore ho, oltre a quella che dici tu, anche una del 16/4 denominata "TSDZ2-v0.20.1-fix_assist_without_pedaling.hex" (attualmente installata sulla bici) e sul desktop una più recente del 05/05 denominata "TSDZ2-v0.20.1-update_fix_overrun-LCD3_version.hex".
Evidentemente mi sono dimenticato di archiviare quest'ultima e quindi non ricordo chi l'ha sviluppata e se è effettivamente l'ultima.
Chiedo allora a mbrusa se... ne rivendica la paternità.

Ciao, hai ragione ho controllato il 5 maggio nè ha rilasciata un'altra:
https://endless-sphere.com/forums/download/file.php?id=272811
spero che sia davvero l'ultima
thineight Inserito il - 27/05/2020 : 08:12:46
zappan ha scritto:

thineight ha scritto:

Scusate, mi sono un attimo perso su quale sia l'ultima versione per LCD3. La trovo su github o devo scorrere indietro questo thread per recuperare l'hex?

Grazie e buona serata.


Ciao, io l'ho scaricata da endeless e credo sia l'ultima: https://endless-sphere.com/forums/download/file.php?id=269437 , qui l'ho vista ma su github non credo che ci sia.

Grazie zappan, ma credo che questa che dici del 30 marzo non sia l'ultima.

Nelle mie cartelle dedicate al motore ho, oltre a quella che dici tu, anche una del 16/4 denominata "TSDZ2-v0.20.1-fix_assist_without_pedaling.hex" (attualmente installata sulla bici) e sul desktop una più recente del 05/05 denominata "TSDZ2-v0.20.1-update_fix_overrun-LCD3_version.hex".
Evidentemente mi sono dimenticato di archiviare quest'ultima e quindi non ricordo chi l'ha sviluppata e se è effettivamente l'ultima.
Chiedo allora a mbrusa se... ne rivendica la paternità.
zappan Inserito il - 27/05/2020 : 07:59:44
thineight ha scritto:

Scusate, mi sono un attimo perso su quale sia l'ultima versione per LCD3. La trovo su github o devo scorrere indietro questo thread per recuperare l'hex?

Grazie e buona serata.


Ciao, io l'ho scaricata da endeless e credo sia l'ultima: https://endless-sphere.com/forums/download/file.php?id=269437 , qui l'ho vista ma su github non credo che ci sia.
thineight Inserito il - 26/05/2020 : 22:00:26
Scusate, mi sono un attimo perso su quale sia l'ultima versione per LCD3. La trovo su github o devo scorrere indietro questo thread per recuperare l'hex?

Grazie e buona serata.
buranel Inserito il - 26/05/2020 : 14:14:10
Ciao Mbrusa ho fatto una prova veloce con la 20beta1A senza fix overrun si comporta allo stesso modo c'e latenza quando si smette di pedalare/si riparte
Ho provato solo in Emtb e in Torque e confermo che in Torque c'e meno latenza anche con questa versione.
Ho usato gli stessi parametri di configurazione anche assist whitout pedal ma è molto meno reattiva in partenza da fermo probabilmente perche manca il parametro ADC range
mbrusa Inserito il - 26/05/2020 : 09:39:29
Ok.
Secondo me i sensori dei freni sono utili quando ti fermi, ma per la partenza in salita sarebbe peggio per l'ingranaggio blu, se si rilasciano i freni quando si è già in piedi sul pedale, prenderebbe una botta.
Senza sensori è più naturale il controllo, sentendo il motore che inizia a spingere viene automatico rilasciare i freni.
buranel Inserito il - 26/05/2020 : 09:13:22

In merito al mezzo giro di latenza prima di avere assistenza quando si smette di pedalare e si riprende, lo fa anche con "Start-up assistance without pedaling" abilitato?
Lo avevi notato anche con la prima versione? mb.20beta1.A senza la modifica fix overrun.

Ciao Mbrusa riguardo start up assistance lo avevo provato con valore 30 ma era troppo sensibile in piano non da problemi ma in salita sullo scassato ho paura di rompere l'ingranaggio blu...ci vorrebbero i sensori freni ma non mi va di montarli penso di abbassarlo ancora un pelino magari a 18.
Riguardo alla latenza mi sembra lo faccia ancora anche cosi comunque faro ulteriori prove
Nota: secondo me in torque mode la latenza è quasi nulla si nota molto di piu in pwr e in emtb
con la prima versione beta1A non ricordo ma siccome c'e l'ho ancora posso provare e poi ti dico.
mbrusa Inserito il - 26/05/2020 : 08:57:32
buranel ha scritto:

Ciao Mbrusa ho tardato a rispondere causa poco tempo disponibile x fare prove
Ho provato come da te indicato cambiare i valori del ramp down sia a 0 8 e 16 sul mio motore non noto molta differenza unica cosa è l'allungamento del tempo di overrun
Quando si smette di pedalare e si riprende c'e sempre piu di mezzo giro di latenza prima di avere assistenza. Con ultima versione anche a zero non noto piu la botta sul carro posteriore ogni tanto pero il motore fa circa mezzo giro da solo (forse è il valore 8 sul torque ADC offset devo verificarlo). Una cosa positiva invece è che sono riuscito ad avere assistenza da fermo in salita, Ho abilitato Start up without pedaling e l'assist thresold a 20 a 10 era poco e il pedal torque ADC offset a 8...come premo sui pedali riesco a partire da fermo senza fare il mezzo giro adesso è simile all altra mi bici nativa con motore Bafang.

Ciao buranel, finalmente qualcuno che ha provato e apprezzato l'abbinamento "Start-up assistance without pedaling" con "Pedal torque offset adjustment".
Io "Assist without pedaling threshold" lo tengo a 30, mi piace sentire il motore che spinge subito solo appoggiando il piede sul pedale...

Ogni tanto il motore fa mezzo giro perchè in quel momento è disabilitato overrun.
Con abilitato "Start-up assistance without pedaling" ho dovuto disabilitare overrun il primo giro di pedali.
Ogni tanto, devo ancora capire perchè, si disabilita anche dopo.

In merito al mezzo giro di latenza prima di avere assistenza quando si smette di pedalare e si riprende, lo fa anche con "Start-up assistance without pedaling" abilitato?
Lo avevi notato anche con la prima versione? mb.20beta1.A senza la modifica fix overrun.
buranel Inserito il - 25/05/2020 : 23:34:48

andrea 104KG ha scritto:

Siete incontentabili... non amo smanettare coi firmware, quando uno va bene io mi fermo. Attualmente è il caso della prima versione per lcd03 con overrun, mi va benissimo, ormai ho fatto più di 100km, stessa potenza della versione buba, un pò rallentato in partenza ma siccome viaggio sempre molto corto fare mezzo giro di pedalata non mi da nessun fastidio...
Peraltro adesso ho montato il 46 dietro (34 davanti) e ieri sono riuscito, piano ovviamente, a fare 27km con 770 mt di dislivello sempre in legal settato a 380w massimi, anche ben oltre il 20% e con lo zaino sono ben oltre i 105kg e 26kg di bici.... per me il motorello è il massimo :-)


Ciao Andrea io sono contentissimo del motore e del firmare a dire il vero uso di piu questa bici che quella nativa bafang
anche le mie medie sono intorno a 8 kmh in salita faccio giri di30 35 km con dislivelli di 100/1300.
Ho fatto i test che Mbrusa aveva suggerito e riporto le mie impressioni (come sappiamo tutti i motori sono uno diverso dell'altro ed anche l'uso che se ne fa quindi quello che va bene/male per me non è detto sia uguale per un'altro) cerco per quanto mi sia possibile di fare i test con metodo non a casaccio e se c'e qualcosa da segnalare lo scrivo. Apprezzo e rispetto enormemente il lavoro che ha fatto Mbrusa ha fatto anche troppo!! poi se a sua discrezione ritiene utili le mie impressioni bene altrimenti va benissimo cosi.
andrea 104KG Inserito il - 25/05/2020 : 22:49:19
Siete incontentabili... non amo smanettare coi firmware, quando uno va bene io mi fermo. Attualmente è il caso della prima versione per lcd03 con overrun, mi va benissimo, ormai ho fatto più di 100km, stessa potenza della versione buba, un pò rallentato in partenza ma siccome viaggio sempre molto corto fare mezzo giro di pedalata non mi da nessun fastidio...
Peraltro adesso ho montato il 46 dietro (34 davanti) e ieri sono riuscito, piano ovviamente, a fare 27km con 770 mt di dislivello sempre in legal settato a 380w massimi, anche ben oltre il 20% e con lo zaino sono ben oltre i 105kg e 26kg di bici.... per me il motorello è il massimo :-)
Ovviamente nessuno accetterebbe una media di 10-12kmh, ma a me va bene così!
buranel Inserito il - 25/05/2020 : 19:48:21
Ciao Mbrusa ho tardato a rispondere causa poco tempo disponibile x fare prove
Ho provato come da te indicato cambiare i valori del ramp down sia a 0 8 e 16 sul mio motore non noto molta differenza unica cosa è l'allungamento del tempo di overrun
Quando si smette di pedalare e si riprende c'e sempre piu di mezzo giro di latenza prima di avere assistenza. Con ultima versione anche a zero non noto piu la botta sul carro posteriore ogni tanto pero il motore fa circa mezzo giro da solo (forse è il valore 8 sul torque ADC offset devo verificarlo). Una cosa positiva invece è che sono riuscito ad avere assistenza da fermo in salita, Ho abilitato Start up without pedaling e l'assist thresold a 20 a 10 era poco e il pedal torque ADC offset a 8...come premo sui pedali riesco a partire da fermo senza fare il mezzo giro adesso è simile all altra mi bici nativa con motore Bafang.
zappan Inserito il - 25/05/2020 : 14:14:26
Chaussy ha scritto:

zappan ha scritto:

Chaussy ha scritto:

Ciao a tutti,
ho da circa un annetto questo motore e stavo pensando di provare a fare un flash del firmware, qualcuno ha un link di un tutorial?Ho acquistato un TM32F103C8T6 STM8 STM32 ST-Link V2, ho discrete nozioni informatiche e buona manualità.
Nel frattempo vi chiedo un'altra informazione, ho usufruito di un incentivo regionale e ho comprato una Ebike per mia moglie il nuovo modello di Atala con la batteria integrata con AM80 sport, rispetto al nostro motore c'è differenza?
Buona giornata a tutti e grazie.

Ciao puoi provare a leggerti questo post:
http://www.jobike.it/forum/topic.asp?TOPIC_ID=77830
Per quanto riguarda l'altra bici magari ci farai sapere tu le differenze che riscontrerai


Grazie per la risposta, ma oltre al ST link devo acquistare altro?
Il connettore femmina a 6 pin uguale a quello del sensore di velocità non è obbligatorio giusto?Serve per semplificare l'operazione?
Grazie a tutti.


Ciao prego , allora devi procurarti una prolunga http://www.pswpower.com/ven.php?cargo.2019-as-bn75 e tagliarla per utilizzare i fili che ti servono per comunicare con il controller del motore:

Immagine:

100,74 KB

anche nelle prime pagine di questo post trovi altre valide informazioni su come intervenire.
mbrusa Inserito il - 25/05/2020 : 12:23:53
thineight ha scritto:
Purtroppo riesco ad effettuare le prove con tempi un po' dilatati... oggi mi ero messo per provare quanto suggerivi, ma prima volevo provare ancora la configurazione attuale.
Ho provato a passare tra la calibrazione standard e avanzata del cadence sensor e dopo qualche andirivieni tra i settaggi la corona ha iniziato ad arrestarsi correttamente, senza cioè alcuna ripartenza. Il settaggio di ramp_down è rimasto a 15, ma proverò a ridurlo.

Mi viene il dubbio che prima avessi il settaggio standard del cadence.
Domani osserverò meglio il comportamento, e a seguire proverò ad impostare a 8 il ramp_down come suggerito.

Domanda sul manuale: sul "manuale operativo" pdf del display è indicato che la modalità cadence standard si attiva al LIVELLO 1-->E04 (menu condiviso però con la calibrazione torque), mentre nel "manuale integrativo" è riportato che le due modalità cadence si switchano al LIVELLO 3 --> E04. Credo sia corretta la seconda, confermi? Nel caso sarebbe da aggiornare il pdf.

Ultima domanda: vedo che dal menu di calibrazione del range torque il valore quando salgo sui pedali è superiore a 160, conviene lasciare il default o meglio impostarlo ugualmente? Avevo letto che valori superiori a 160 verranno comunque ignorati.

Grazie mille

Si nel caso di differenze tra i due manuali, vale quello integrativo.
Il primo è rimasto quello della versione precedente, avrei dovuto rivedere anche la traduzione...

Esatto se il valore del torque è maggiore di 160 non è necessario modificarlo, puoi lasciare 160.
Chaussy Inserito il - 25/05/2020 : 10:52:53
zappan ha scritto:

Chaussy ha scritto:

Ciao a tutti,
ho da circa un annetto questo motore e stavo pensando di provare a fare un flash del firmware, qualcuno ha un link di un tutorial?Ho acquistato un TM32F103C8T6 STM8 STM32 ST-Link V2, ho discrete nozioni informatiche e buona manualità.
Nel frattempo vi chiedo un'altra informazione, ho usufruito di un incentivo regionale e ho comprato una Ebike per mia moglie il nuovo modello di Atala con la batteria integrata con AM80 sport, rispetto al nostro motore c'è differenza?
Buona giornata a tutti e grazie.

Ciao puoi provare a leggerti questo post:
http://www.jobike.it/forum/topic.asp?TOPIC_ID=77830
Per quanto riguarda l'altra bici magari ci farai sapere tu le differenze che riscontrerai


Grazie per la risposta, ma oltre al ST link devo acquistare altro?
Il connettore femmina a 6 pin uguale a quello del sensore di velocità non è obbligatorio giusto?Serve per semplificare l'operazione?
Grazie a tutti.
zappan Inserito il - 25/05/2020 : 09:41:56
mbrusa ha scritto:

Ciao zappan, vedo che insisti...
Ti piacerebbe proprio avere eMTB sempre disponibile a livello 4.
Ci penso dai, se non è troppo complicato.

Ciao, si capisco che ti stravolge il progetto, ma lo trovo davvero molto funzionale , cmq sempre grazie per il tuo lavoro.
thineight Inserito il - 24/05/2020 : 22:57:23
mbrusa ha scritto:
E' chiaro thineight, aumentando il valore di "Motor ramp down additional" la differenza c'è, ma con cadence sensor in modalità avanzata l'effetto è poco evidente.
Potresti provare anche in modalità standard con i valori che ho cosigliato a buranel, 8 e 16?
Se in modalità standard non sentirai più questo contraccolpo, avrò un riferimento su come intervenire in modalità avanzata.


Purtroppo riesco ad effettuare le prove con tempi un po' dilatati... oggi mi ero messo per provare quanto suggerivi, ma prima volevo provare ancora la configurazione attuale.
Ho provato a passare tra la calibrazione standard e avanzata del cadence sensor e dopo qualche andirivieni tra i settaggi la corona ha iniziato ad arrestarsi correttamente, senza cioè alcuna ripartenza. Il settaggio di ramp_down è rimasto a 15, ma proverò a ridurlo.

Mi viene il dubbio che prima avessi il settaggio standard del cadence.
Domani osserverò meglio il comportamento, e a seguire proverò ad impostare a 8 il ramp_down come suggerito.

Domanda sul manuale: sul "manuale operativo" pdf del display è indicato che la modalità cadence standard si attiva al LIVELLO 1-->E04 (menu condiviso però con la calibrazione torque), mentre nel "manuale integrativo" è riportato che le due modalità cadence si switchano al LIVELLO 3 --> E04. Credo sia corretta la seconda, confermi? Nel caso sarebbe da aggiornare il pdf.

Ultima domanda: vedo che dal menu di calibrazione del range torque il valore quando salgo sui pedali è superiore a 160, conviene lasciare il default o meglio impostarlo ugualmente? Avevo letto che valori superiori a 160 verranno comunque ignorati.

Grazie mille
mbrusa Inserito il - 24/05/2020 : 20:21:12
Ciao zappan, vedo che insisti...
Ti piacerebbe proprio avere eMTB sempre disponibile a livello 4.
Ci penso dai, se non è troppo complicato.
zappan Inserito il - 23/05/2020 : 21:48:18
mbrusa ha scritto:

zappan ha scritto:

Ciao Mbrusa e ancora come sempre complimenti per il tuo splendido lavoro, ho installato ieri l'ultima versione che hai rilasciato ed ho fatto un giretto di prova, non c'è che dire un solo aggettivo "ottimo"
Mi dispiace solo che, mentalmente, non riesco piu' a seguire e provare la moltitudine di settaggi che il tuo SW propone ma vedo con molto piacere che nuovi utenti si cimentano con passione a darti i riscontri per il miglioramento del progetto, li seguo davvero con molto piacere. Davvero buone pedalate a tutti


Ciao zappan, che piacere risentirti.
Moltitudine di settaggi? Dai...
E' solo un mix di versioni che conosci già bene.
Quella di marcoq, quella di buba e la mia precedente.


Ciao Mbrusa, sono d'accordo il tuo è un mix di versioni che conosco bene avendole provate tutte e per questo vorrei chiederti una cosa: oggi ho ripreso la bici con LCD3 ed ho trovato molto comodo poter utilizzare la configurazione EMTB al max livello di assistenza impostato, la tua versione è sicuramente piu' completa avendo 4 livelli differenziati di potenza, ma la trovo scomoda dovendola settare in movimento, ti faccio un esempio, nei tratti asfaltati uso Power poi appena imbocco un sentiero passo con pochi clic su EMTB che ti permette una pedalata oltretutto molto simile alla Torque ottenendo la massima soddisfazione di pedalata in fuoristrada, che ne pensi?
Davet87 Inserito il - 23/05/2020 : 21:34:16
Quindi può dipendere da quello come pensavo inizialmente?
Adesso mi procuro un connettore, lo sistemo e ti faccio sapere
mbrusa Inserito il - 23/05/2020 : 21:31:41
Davet87 ha scritto:

Ho rotto un piedino del controller che si collega al sensore di velocità. Ora non mi segna più la velocità ed ho notato che, in questa situazione, il motore ha ha di nuovo l effetto di trascinamento smesso di pedalare. Oltretutto in certi casi sembra restare accelerato per qualche secondo

E' possibile, senza il sensore di velocità il motore funziona lo stesso ma non allo stesso modo.
mbrusa Inserito il - 23/05/2020 : 21:23:20
Davet87 ha scritto:

Quindi se è come dici tu, la calibrazione del Sensore di cadenza che ho fatto, non è andata a buon fine

La calibrazione del sensore di cadenza non dipende dal sensore di velocità.
Davet87 Inserito il - 23/05/2020 : 21:17:51
Quindi se è come dici tu, la calibrazione del Sensore di cadenza che ho fatto, non è andata a buon fine
Davet87 Inserito il - 23/05/2020 : 21:14:40
Ho rotto un piedino del controller che si collega al sensore di velocità. Ora non mi segna più la velocità ed ho notato che, in questa situazione, il motore ha ha di nuovo l effetto di trascinamento smesso di pedalare. Oltretutto in certi casi sembra restare accelerato per qualche secondo
mbrusa Inserito il - 23/05/2020 : 21:10:22
Davet87 ha scritto:

@Mbrusa, ciao, ma L funzione fix overrun è collegata direttamente al sensore di velocità per la gestione?

No, in fix overrun per controllare se i pedali sono fermi si usa il sensore di cadenza.
La velocità è utilizzata in una funzione già esistente per calcolare la rampa di decelerazione quando diminuisce l'assistenza (meno cadenza e/o meno forza).
Con fix overrun, smettendo di pedalare la rampa di decelerazione è impostata al minimo indipendentemente dalla velocità.
Qualche Problema?
Davet87 Inserito il - 23/05/2020 : 12:46:19
@Mbrusa, ciao, ma L funzione fix overrun è collegata direttamente al sensore di velocità per la gestione?

zappan Inserito il - 22/05/2020 : 21:15:32
Chaussy ha scritto:

Ciao a tutti,
ho da circa un annetto questo motore e stavo pensando di provare a fare un flash del firmware, qualcuno ha un link di un tutorial?Ho acquistato un TM32F103C8T6 STM8 STM32 ST-Link V2, ho discrete nozioni informatiche e buona manualità.
Nel frattempo vi chiedo un'altra informazione, ho usufruito di un incentivo regionale e ho comprato una Ebike per mia moglie il nuovo modello di Atala con la batteria integrata con AM80 sport, rispetto al nostro motore c'è differenza?
Buona giornata a tutti e grazie.

Ciao puoi provare a leggerti questo post:
http://www.jobike.it/forum/topic.asp?TOPIC_ID=77830
Per quanto riguarda l'altra bici magari ci farai sapere tu le differenze che riscontrerai
saimaza Inserito il - 22/05/2020 : 19:17:28
mbrusa ha scritto:

saimaza ha scritto:
Buongiorno.
Allego il file per vedere la configurazione. Il motore ora ha un'ottima spinta su eMTB e salite in modalità coppia. Ho iniziato a 130 e l'ho abbassato a 120, non ho notato alcuna differenza apprezzabile.
Un saluto.

Allegato: 20200520-141050CEST.ini
1,11 KB

Non si riesce a scaricare il file, dovresti fare uno zip.
Non hai notato alcuna differenza apprezzabile, da 130 a 120?
Ma rispetto a quando era 160 è meglio, ho capito bene?


Buongiorno.
In 130 o 120 si nota un notevole miglioramento, prima che la modalità di alimentazione spingesse più della modalità coppia o eMTB, ora mi piace di più la modalità eMTB.




Allegato: 20200520-141050CEST.zip
875 Bytes
Chaussy Inserito il - 22/05/2020 : 14:55:16
Ciao a tutti,
ho da circa un annetto questo motore e stavo pensando di provare a fare un flash del firmware, qualcuno ha un link di un tutorial?Ho acquistato un TM32F103C8T6 STM8 STM32 ST-Link V2, ho discrete nozioni informatiche e buona manualità.
Nel frattempo vi chiedo un'altra informazione, ho usufruito di un incentivo regionale e ho comprato una Ebike per mia moglie il nuovo modello di Atala con la batteria integrata con AM80 sport, rispetto al nostro motore c'è differenza?
Buona giornata a tutti e grazie.
mbrusa Inserito il - 22/05/2020 : 08:37:50
saimaza ha scritto:
Buongiorno.
Allego il file per vedere la configurazione. Il motore ora ha un'ottima spinta su eMTB e salite in modalità coppia. Ho iniziato a 130 e l'ho abbassato a 120, non ho notato alcuna differenza apprezzabile.
Un saluto.

Allegato: 20200520-141050CEST.ini
1,11 KB

Non si riesce a scaricare il file, dovresti fare uno zip.
Non hai notato alcuna differenza apprezzabile, da 130 a 120?
Ma rispetto a quando era 160 è meglio, ho capito bene?
saimaza Inserito il - 20/05/2020 : 14:19:48
mbrusa ha scritto:

saimaza ha scritto:
Grazie mbrusa.
Seguirò i tuoi consigli e inizierò con valori elevati e li abbasserò se necessario.
In " TORQUE ASSIST" con il valore standard di 160 nel livello di assistenza 4 Soffro molto sulle piste, mi costa meno salire nel livello di assistenza 2 in modalità " POWER ASSIST”.
Spero che con i nuovi valori cambi in meglio.
Un saluto

In torque assist vedrai sicuramente la differenza.
Poi fammi sapere il valore di "Pedal torque adc range" che utilizzerai.
Mi servirà per ottimizzare il calcolo. Grazie


Buongiorno.
Allego il file per vedere la configurazione. Il motore ora ha un'ottima spinta su eMTB e salite in modalità coppia. Ho iniziato a 130 e l'ho abbassato a 120, non ho notato alcuna differenza apprezzabile.
Un saluto.

Allegato: 20200520-141050CEST.ini
1,11 KB
Matteov82 Inserito il - 19/05/2020 : 12:45:30
In merito alla versione io ti posso dire che usando la penultima versione,sulla bici impostata a motore 36 v batteria da 48,con accelerazione al 5% e ramp additional a zero la bici decolla.ha una ripresa impressionante e non ho nessun problema
mbrusa Inserito il - 19/05/2020 : 12:04:58
Se non hai problemi in partenza con "Motor ramp down additional" a zero, probabilmente hai la versione dove avevo disabilitato overrun il primo giro di pedali. Però il tempo di arresto non è sempre uguale.
Matteov82 Inserito il - 19/05/2020 : 11:52:29
In merito alla versione io ti posso dire che usando la penultima versione,sulla bici impostata a motore 36 v batteria da 48,con accelerazione al 5% e ramp additional a zero la bici decolla.ha una ripresa impressionante e non ho nessun problema
mbrusa Inserito il - 19/05/2020 : 11:44:30
Ok, stiamo dicendo la stessa cosa ma per scopi diversi...
Matteov82 Inserito il - 19/05/2020 : 11:31:49
Ma infatti io ti sto dicendo che ho dovuto rimappare perché nella 29 il diametro della ruota settato nel configuratore era 2270 e montando il kit sulla 26,pur mettendo solo da display il diametro a 26,le velocità erano errate.per cui sono stato costretto a riprogrammare dal configuratore con diametro ruota 26 quindi 2050 mm e le velocità si sono ricalibrate correttamente.il tutto testato con gps esterno.

Forum Indipendente Biciclette Elettriche, Pieghevoli e Utility © 2000-06 jobike Torna all'inizio della Pagina
Questa pagina è stata generata in 0,82 secondi. Versione 3.4.06 by Modifichicci - Herniasurgery.it | Distribuito Da: Massimo Farieri - www.superdeejay.net | Powered By: Platinum Full - Snitz Forums 2000 Version 3.4.06
Creative Commons License
Questo/a opera è pubblicato sotto una Licenza Creative Commons.