Forum Indipendente Biciclette Elettriche, Pieghevoli e Utility

Forum Indipendente Biciclette Elettriche, Pieghevoli e Utility
[ Home | Registrati | Discussioni Attive | Discussioni Recenti | Segnalibro | Msg privati | Sondaggi Attivi | Utenti | Album Fotografico | Download | Links | FAQ |Ricerca Avanzata | le biciclette provate da noi ] mago job
Ultime novità: * per evitare lo spam, l'iscrizione attende l'approvazione degli Amministratori, un po' di pazienza per favore

attenzione che la mail automatica di conferma iscrizione non sempre funziona, provare ad accedere lo stesso o scrivere in amministrazione

* per comunicazioni scrivere a postmaster@jobike.it o contattare uno degli amministratori (job o pixbuster)

* qui tutti i modelli testati da noi a confronto

Nome Utente:
Password:
Salva Password
Password Dimenticata?

 Tutti i Forum
 Discussioni
 Kit e fai da te
 TSDZ2 modifiche e documentazione varia
 Nuova Discussione  Rispondi
 Versione Stampabile Bookmark this Topic Aggiungi Segnalibro
I seguenti utenti stanno leggendo questo Forum Qui c'è:
Pagina Precedente | Pagina Successiva
Autore Discussione Precedente Discussione Discussione Successiva
Pagina: di 74

mbrusa
Utente Medio


Lombardia


326 Messaggi

Inserito il - 27/07/2019 : 19:25:22  Mostra Profilo  Rispondi Quotando
Ciao Rotolo, io un dato ufficiale non l'avevo trovato.
Da esperienze altrui sembra che già con 0,5A va in protezione.

City Bike TSDZ2 36V/250W e XH18. Batteria 36V 17,5Ah Km 3100
Btwin 7 bia TSDZ2 36V/250W e XH18. Batteria 36V 17,5Ah Km 400
Open source firmware mb.20beta1.B VLCD5-VLCD6-XH18
Torna all'inizio della Pagina

Chri27.5
Utente Medio



426 Messaggi

Inserito il - 28/07/2019 : 21:32:29  Mostra Profilo  Rispondi Quotando
[quote]marcoq ha scritto:

Buongiorno a tutti.
Ho rilasciato la release 0.3.7 del configuratore java e la release M0.19.B del firmware per la scheda controller.
Cosa è stato fatto:
- Sono stati abilitati i campi 1/6 e 6/6 per ottimizzare il calcolo e la visualizzazione del livello di carica per il VLCD5.
- E' stato risolto il bug che in alcuni casi poteva influire sulla resistenza all'indietro del motore.
- E' stato risolto il bug che riguarda il throttle, ora quando il motore si ferma viene automaticamente disabilitato fino al nuovo riavvio.
- Nel codice è stata ottimizzata la gestione delle variabili.

Ritengo che questa release sia praticamente stabile e soddisfacente... ora sto aspettando su Endless il rilascio della nuova release 20.0... dopo di che comincerò a lavorare su quella.
Buone pedalate!!

Ciao marcoq,
oggi primo giro con la nuova 3.7, confermo che la resistenza all'indietro è sistemata e potrebbe essere effettivamente una versione stabile come dicevi pure tu , solamente un problema ho riscontrato con il motore, è rimasto praticamente inserito anche senza pedalare, non sono riuscito a spegnerlo dal comando ma solamente staccando la batteria, potresti guardarci quando hai un po di tempo?
Per le tacche su vlcd5 devo capirci un po meglio, ho impostato solamente
1/6
6/6
e sembra funzionare bene, posso impostare anche
4/6
3/6
2/6 ???
Oggi ho fatto 15 km, 10 in salita e 5 in discesa per via del maltempo,solamente due tacche ho consumato come mi sarei aspettato, per cui vi aggiornerò su questo solo dopo aver completamente esaurito la batteria.
Cmq non ho parole per ringraziarti per il tuo meraviglioso lavoro.
Torna all'inizio della Pagina

microchip
Utente Attivo


Veneto


756 Messaggi

Inserito il - 28/07/2019 : 21:36:25  Mostra Profilo Invia a microchip un Messaggio Privato  Rispondi Quotando
Quelli dell'inserimento del motore mi è successo un paio di volte anche con la versione 3.3 . Quello della velocità resta fisso a 9,9 km e il motore sempre in tiro. Però sono riuscito a spegnerlo tenendo premuto per un po' il tasto di spegnimento. Riacceso e ripartito regolarmente.

Roberto
Torna all'inizio della Pagina

Chri27.5
Utente Medio



426 Messaggi

Inserito il - 28/07/2019 : 21:49:35  Mostra Profilo  Rispondi Quotando
microchip ha scritto:

Quelli dell'inserimento del motore mi è successo un paio di volte anche con la versione 3.3 . Quello della velocità resta fisso a 9,9 km e il motore sempre in tiro. Però sono riuscito a spegnerlo tenendo premuto per un po' il tasto di spegnimento. Riacceso e ripartito regolarmente.


Ciao microchip,
ho provato a tenere premuto il tasto per spegnerlo ma non dava nessun segno di vita il display, si è resettato tutto solo dopo staccato la batteria.

Modificato da - Chri27.5 in data 28/07/2019 22:00:14
Torna all'inizio della Pagina

andrea 104KG
Utente Master


Marche


8769 Messaggi

Inserito il - 28/07/2019 : 22:39:18  Mostra Profilo Invia a andrea 104KG un Messaggio Privato  Rispondi Quotando
Cavolo ma se succede a uno stop? È pericolosissimo se come nella maggior parte dei casi non si hanno i cut off sui freni..
Torna all'inizio della Pagina

marcoq
Utente Medio



258 Messaggi

Inserito il - 28/07/2019 : 23:37:19  Mostra Profilo  Rispondi Quotando
Bisogna vedere se anche su Endless qualcuno ha avuto lo stesso problema... personalmente non mi è mai successo...

Modificato da - marcoq in data 28/07/2019 23:37:47
Torna all'inizio della Pagina

andrea 104KG
Utente Master


Marche


8769 Messaggi

Inserito il - 29/07/2019 : 01:10:55  Mostra Profilo Invia a andrea 104KG un Messaggio Privato  Rispondi Quotando
Fortunatamente neanche a me nelle versioni per lcd03.. ma adesso mi mettete una certa paura, se il motore non si ferma può voler dire finire sotto un'auto che non ha neanche il tempo di frenare.. se poi è un camion... non va bene troppo pericoloso!
Torna all'inizio della Pagina

microchip
Utente Attivo


Veneto


756 Messaggi

Inserito il - 29/07/2019 : 07:43:32  Mostra Profilo Invia a microchip un Messaggio Privato  Rispondi Quotando
No da quel punto di vista l'erogazione era debole e si fermava tranquillamente con i freni.

Roberto
Torna all'inizio della Pagina

thineight
Utente Medio


Veneto


323 Messaggi

Inserito il - 29/07/2019 : 08:29:28  Mostra Profilo  Rispondi Quotando
microchip ha scritto:

No da quel punto di vista l'erogazione era debole e si fermava tranquillamente con i freni.


Ciao, come detto in passato conviene montare i sensori ai freni, ti aiutano in montagna a preservare il motore e l'ingranaggio blu da fermate improvvise (tipo radici, sassi etc), ti fermano la bici in caso di malfunzionamento del sensore di torsione, nonché da bachi software di entrambe le versioni originale e open source.
Se poi avete il vlcd5 esiste la versione direttamente compatibile col display stesso così evitate il taglia e salda dei cavi.

https://m.it.aliexpress.com/item/32958044152.html

Buone pedalate

MTB KTM Ultra 29" (TSDZ2 36V open source firmware v.0.20 beta1)
City bike DAYTONA 28" (TSDZ2 36V open source firmware mb.20beta1.A per VLCD5-VLCD6-XH18)
Torna all'inizio della Pagina

zappan
Utente Senior


Sicilia


1104 Messaggi

Inserito il - 29/07/2019 : 09:02:31  Mostra Profilo Invia a zappan un Messaggio Privato  Rispondi Quotando
Ciao, a mè fortunatamente, non è mai successo che il motore rimanesse inserito nè con LCD3 nè con il SW di Marcoq e neanche con l'originale, certamente il montaggio dei sensori dei freni è sicuramente utile e risolutivo

Ex @MTB Raleigh BPM 36V LifePo4 36V-12Ah Watts'Up Km 7250 dal 10 2009 al 08 2015
Ex @MTB LITE K2 Cute Q100 24V Litio 24V-8Ah Km 12350 dal 5 2011 al 10 2015
@MTB Raleigh TDSZ2 LCD3 Flexible OpenSource 0.20.1 by Casainho-Buba 36V 14.5Ah Litio kM 989 dal 07 2018
@MTB De Vinci Troy TDSZ2 VLCD6 SW By Marcoq-Mbrusa V20beta1 48V Litio 9,6Ah Km 902 dal 09 2018; con Bluetooth ESP32 e SW Ver.3 di Mspider65 da 05 2020:
Torna all'inizio della Pagina

Mauri78
Utente Medio


Piemonte


483 Messaggi

Inserito il - 29/07/2019 : 09:47:36  Mostra Profilo Invia a Mauri78 un Messaggio Privato  Rispondi Quotando
Ciao a tutti,
continuo a scrivere dopo i miei primi test del FW 0.19.0.
Il responso è che mi piace :-) l'ho settato così:
Max power 350W
livelli di assistenza 5 configurati come di default
Max current 16A
Il motorello, in effetti, sembra un toro, non ho mai usato un livello superiore al 3, quindi credo che li risetterò in basso. Su strada raggiungi facilmente velocità decisamente elevate e l'erogazione è fantastica!
Ora devo capire come si comporta con le batterie e quanta energia mangia.

Volevo chiedervi se qualcuno ha notato una certa imprecisione del voltmetro interno, la tensione misurata che leggo sul menù 3.1(o meglio 3.0 piccolo bug della documentazione) mi sembra decisamente più bassa di quella effettiva, ho anche provato a mettere a 0 la resistenza interna della batteria(menù di configurazione 1.3 valore di default 130 mOhm) ma non cambia, anche perchè il valore di resistenza interna incide solo sotto carico, a vuoto non dovrebbe cambiare nulla.
Stamattina con batteria appena staccata dal charger misurava 41V... devo fare delle prove e controllare la taratura del charger ma mi sembra strano... molto strano...

Maurizio
Torna all'inizio della Pagina

andrea 104KG
Utente Master


Marche


8769 Messaggi

Inserito il - 29/07/2019 : 09:53:51  Mostra Profilo Invia a andrea 104KG un Messaggio Privato  Rispondi Quotando
Se parli di lcd03 ne ho due, sul 48v è discretamente preciso a carica completa da 54.4v. Sul 36v invece sgarra quasi un volt, a carica completa da 41.6v.
Torna all'inizio della Pagina

Mauri78
Utente Medio


Piemonte


483 Messaggi

Inserito il - 29/07/2019 : 14:31:14  Mostra Profilo Invia a Mauri78 un Messaggio Privato  Rispondi Quotando
Si, parlo di LCD03, in effetti io ho la versione a 36V con batteria a 36V e sgarra di circa 1V.
Torna all'inizio della Pagina

manureverse
Nuovo Utente


Piemonte


42 Messaggi

Inserito il - 29/07/2019 : 15:44:45  Mostra Profilo  Rispondi Quotando
Buongiorno a tutti, si a me è capitato che rimanesse inserito il motore a piena accelerazione. Per fortuna ero in paese e non ho avuto problemi, l'ho guidato per un po ed era come se accellerasse da solo. In montagna sarebbe stato rischioso. Il fatto se sia successo a diversi di noi significa che il problema esiste e succede abbastanza spesso.
Per il resto sono davvero molto soddisfatto del livello di stabilità raggiunto.
Ora potendo inserire i valori a batteria piena su vlcd5 la misurazione delle tacche è molto precisa
Torna all'inizio della Pagina

thineight
Utente Medio


Veneto


323 Messaggi

Inserito il - 29/07/2019 : 16:25:24  Mostra Profilo  Rispondi Quotando
manureverse ha scritto:

Buongiorno a tutti, si a me è capitato che rimanesse inserito il motore a piena accelerazione. Per fortuna ero in paese e non ho avuto problemi, l'ho guidato per un po ed era come se accellerasse da solo. In montagna sarebbe stato rischioso. Il fatto se sia successo a diversi di noi significa che il problema esiste e succede abbastanza spesso.
Per il resto sono davvero molto soddisfatto del livello di stabilità raggiunto.
Ora potendo inserire i valori a batteria piena su vlcd5 la misurazione delle tacche è molto precisa

Riesci ad indicare la versione che usi, i settaggi (screenshot) e la procedura per riprodurre il bug?
Sarebbe sicuramente utilissimo per gli utenti e soprattutto per marcoq al fine di sistemare il problema.

MTB KTM Ultra 29" (TSDZ2 36V open source firmware v.0.20 beta1)
City bike DAYTONA 28" (TSDZ2 36V open source firmware mb.20beta1.A per VLCD5-VLCD6-XH18)
Torna all'inizio della Pagina

zappan
Utente Senior


Sicilia


1104 Messaggi

Inserito il - 29/07/2019 : 17:43:40  Mostra Profilo Invia a zappan un Messaggio Privato  Rispondi Quotando
Non è che per qualche strano motivo si attiva il cruiser control implementato ultimamente da Buba? se impostato con LCD3 a velocità superiore a 8 km se si tiene premuto il pulsante Up si attiva e mantiene la velocità, con il SW di Marcoq questa funzione non dovrebbe esistere ma se il codice è uguale chissà se con qualche Display avviene qualche incongruenza ...

Ex @MTB Raleigh BPM 36V LifePo4 36V-12Ah Watts'Up Km 7250 dal 10 2009 al 08 2015
Ex @MTB LITE K2 Cute Q100 24V Litio 24V-8Ah Km 12350 dal 5 2011 al 10 2015
@MTB Raleigh TDSZ2 LCD3 Flexible OpenSource 0.20.1 by Casainho-Buba 36V 14.5Ah Litio kM 989 dal 07 2018
@MTB De Vinci Troy TDSZ2 VLCD6 SW By Marcoq-Mbrusa V20beta1 48V Litio 9,6Ah Km 902 dal 09 2018; con Bluetooth ESP32 e SW Ver.3 di Mspider65 da 05 2020:
Torna all'inizio della Pagina

microchip
Utente Attivo


Veneto


756 Messaggi

Inserito il - 29/07/2019 : 19:06:47  Mostra Profilo Invia a microchip un Messaggio Privato  Rispondi Quotando
In effetti la sensazione è proprio del cruise control. Ho la versione 3.3 però con last beta code, quindi potrebbe essere che si attivi con chissà quale manovra

Roberto
Torna all'inizio della Pagina

microchip
Utente Attivo


Veneto


756 Messaggi

Inserito il - 29/07/2019 : 19:39:33  Mostra Profilo Invia a microchip un Messaggio Privato  Rispondi Quotando
Vi tiro su il morale. Centro di noleggio pubblico al garda, quelli dove si prendono le bici con la tessera.
Guardate chi c'è



Immagine:

304,9 KB

Immagine:

308,71 KB

Roberto
Torna all'inizio della Pagina

mspider65
Utente Normale


Trentino - Alto Adige


87 Messaggi

Inserito il - 29/07/2019 : 21:14:35  Mostra Profilo Invia a mspider65 un Messaggio Privato  Rispondi Quotando
marcoq ha scritto:

Bisogna vedere se anche su Endless qualcuno ha avuto lo stesso problema... personalmente non mi è mai successo...

Ciao Marco, ti ho inviato un messaggio privato qualche giorno fa.
Torna all'inizio della Pagina

bob125
Utente Normale



53 Messaggi

Inserito il - 29/07/2019 : 22:14:59  Mostra Profilo  Rispondi Quotando
Ciao a tutti ..
Proseguo le prove con motore ori in attesa del st link..sperando di capire la sequenza di installazione programmi...non mi è ancora tutto chiaro..( es: devo installare un altro java?)
ho però un problema, spesso il display vcld6 segna 99KM/h e il motore smette di assistere.. quanto devo mettere vicino il sensore di rotazione e il magnete?...il magnete deve essere in linea con la freccia presente sul sensore?
grazie..
Torna all'inizio della Pagina

andrea 104KG
Utente Master


Marche


8769 Messaggi

Inserito il - 29/07/2019 : 23:04:30  Mostra Profilo Invia a andrea 104KG un Messaggio Privato  Rispondi Quotando
Da me il sensore sta a mezzo centimetro e va bene Ho notato che quando mi si e rotto il sensore (strappo filo in furistrada) il motore andava uguale, invece se si sposta il magnete col sensore presente si ferma tutto per fortuna che lo so...
Invece oggi problemone con la pedivella destra, volevo mettere una corona da 34 anzichè 36 per accorciarmi un minimo e la pedivella sembra saldata. Si è sfilettata con l'estrattore, ho provato a scaldarla a 100 gradi niente, a girarci senza vite per 2 km niente.... dovrò procurarmi un estrattore, speriamo di non fare danni...
Che voi sappiate le pedivelle del bafang vanno bene?
Torna all'inizio della Pagina

marcoq
Utente Medio



258 Messaggi

Inserito il - 29/07/2019 : 23:20:13  Mostra Profilo  Rispondi Quotando
mspider65 ha scritto:

marcoq ha scritto:

Bisogna vedere se anche su Endless qualcuno ha avuto lo stesso problema... personalmente non mi è mai successo...

Ciao Marco, ti ho inviato un messaggio privato qualche giorno fa.


Ciao mspider65... ho controllato... ma recentemente non ho ricevuto alcun messaggio!
Torna all'inizio della Pagina

Rotolo
Utente Attivo


Piemonte


823 Messaggi

Inserito il - 29/07/2019 : 23:24:27  Mostra Profilo Invia a Rotolo un Messaggio Privato  Rispondi Quotando
Andrea usa il cannello ma con la fiamma più larga possibile in modo che prenda tutta la bici, così risolvi tutti i problemi e ne fai una normale senza torturare il motore
Torna all'inizio della Pagina

andrea 104KG
Utente Master


Marche


8769 Messaggi

Inserito il - 29/07/2019 : 23:29:30  Mostra Profilo Invia a andrea 104KG un Messaggio Privato  Rispondi Quotando
Rotolo non è mica colpa mia se la pedivella si è bloccata.... è una gran seccatura e pensare che le ingrasso pure per evitare il blocco...
Torna all'inizio della Pagina

Chri27.5
Utente Medio



426 Messaggi

Inserito il - 29/07/2019 : 23:54:35  Mostra Profilo  Rispondi Quotando
andrea 104KG ha scritto:

Da me il sensore sta a mezzo centimetro e va bene Ho notato che quando mi si e rotto il sensore (strappo filo in furistrada) il motore andava uguale, invece se si sposta il magnete col sensore presente si ferma tutto per fortuna che lo so...
Invece oggi problemone con la pedivella destra, volevo mettere una corona da 34 anzichè 36 per accorciarmi un minimo e la pedivella sembra saldata. Si è sfilettata con l'estrattore, ho provato a scaldarla a 100 gradi niente, a girarci senza vite per 2 km niente.... dovrò procurarmi un estrattore, speriamo di non fare danni...
Che voi sappiate le pedivelle del bafang vanno bene?


Le pedivelle bafang vanno benissimo, anzi la pedivella dx essendo diritta compensa la distanza dal carro rispetto alla pedivella sx.
Per togliere la pedivella bloccata dovresti forare con una punta da 5mm ben affilata la pedivella sul lato,poi usa un'altra punta più grande sullo stesso foro cosi la pedivella si sblocca.
L'ho fatto 15 giorni fà questo lavoro sul mio motore, è stato un gioco da ragazzi togliere la pedivella bloccata.
Torna all'inizio della Pagina

Chri27.5
Utente Medio



426 Messaggi

Inserito il - 29/07/2019 : 23:58:55  Mostra Profilo  Rispondi Quotando
Ciao marcoq,
volevo chiederti, se avendo sostituito le pedivelle originali che misurano 170mm con le nuove di 152mm devo modificare i parametri riguardo il sensore di sforzo, essendo più corte diminuisce la leva di spinta.
Grazie
Torna all'inizio della Pagina

andrea 104KG
Utente Master


Marche


8769 Messaggi

Inserito il - 30/07/2019 : 00:41:30  Mostra Profilo Invia a andrea 104KG un Messaggio Privato  Rispondi Quotando
Grazie chri, ma mica ho ben capito DOVE devo forare
Comunque ho un pò di tempo visto che grazie al tuo suggerimento ho appena ordinato le pedivelle dall'Inghilterra, ci metteranno una 15ina di giorni...

Modificato da - andrea 104KG in data 30/07/2019 00:52:43
Torna all'inizio della Pagina

Chri27.5
Utente Medio



426 Messaggi

Inserito il - 30/07/2019 : 00:54:47  Mostra Profilo  Rispondi Quotando
andrea 104KG ha scritto:

Grazie chri, ma mica ho ben capito DOVE devo forare
Comunque ho un pò di tempo visto che grazie al tuo suggerimento ho appena ordinato le pedivelle dall'Inghilterra, ci metteranno una 15ina di giorni...


Immagine:

400,15 KB
Torna all'inizio della Pagina

mspider65
Utente Normale


Trentino - Alto Adige


87 Messaggi

Inserito il - 30/07/2019 : 08:24:51  Mostra Profilo Invia a mspider65 un Messaggio Privato  Rispondi Quotando
marcoq ha scritto:
Ciao mspider65... ho controllato... ma recentemente non ho ricevuto alcun messaggio!


boh si sara perso..

Comunque l'altro giorno dando un occhiata al tuo codice ho notato un bug che potrebbe essere la causa del problema riscontrato da alcuni di inserimento del motore.

Controlla il file ebike_app.c. Il metodo UART2_IRQHandler, scrive in ui8_rx_buffer alla posizione 8 ma il vettore (e il messaggio dall'LCD) è lungo 7 bytes, quindi va a modificare qualche area di memoria con effetti imprevedibili.
Inoltre, leggendo anche il primo byte del successivo messaggio, viene processato un messaggio ogni due.

if(ui8_rx_counter > 8)
{
ui8_rx_counter = 0;
ui8_state_machine = 0;
ui8_received_package_flag = 1; // signal that we have a full package to be processed
UART2->CR2 &= ~(1 << 5); // disable UART2 receive interrupt
}

Modificato da - mspider65 in data 30/07/2019 08:30:12
Torna all'inizio della Pagina

marcoq
Utente Medio



258 Messaggi

Inserito il - 30/07/2019 : 10:55:12  Mostra Profilo  Rispondi Quotando
mspider65 ha scritto:

marcoq ha scritto:
Ciao mspider65... ho controllato... ma recentemente non ho ricevuto alcun messaggio!


boh si sara perso..

Comunque l'altro giorno dando un occhiata al tuo codice ho notato un bug che potrebbe essere la causa del problema riscontrato da alcuni di inserimento del motore.

Controlla il file ebike_app.c. Il metodo UART2_IRQHandler, scrive in ui8_rx_buffer alla posizione 8 ma il vettore (e il messaggio dall'LCD) è lungo 7 bytes, quindi va a modificare qualche area di memoria con effetti imprevedibili.
Inoltre, leggendo anche il primo byte del successivo messaggio, viene processato un messaggio ogni due.

if(ui8_rx_counter > 8)
{
ui8_rx_counter = 0;
ui8_state_machine = 0;
ui8_received_package_flag = 1; // signal that we have a full package to be processed
UART2->CR2 &= ~(1 << 5); // disable UART2 receive interrupt
}



Grazie mspider65 per la segnalazione... appena posso gli darò un'occhiata!
Torna all'inizio della Pagina

marcoq
Utente Medio



258 Messaggi

Inserito il - 30/07/2019 : 11:57:52  Mostra Profilo  Rispondi Quotando
Come segnalato da mspider65, effettivamente c'è un piccolo bug nella comunicazione seriale... che potrebbe in determinate circostanze causare funzionamenti anomali. Questo bug probabilmente me lo sono "trascinato" tra i vari aggiornamenti... comunque non è recente.
Vedrò se riuscirò a rilasciare un aggiornamento nei prossimi giorni.... questo dimostra che 4 occhi sono meglio di 2!!!
Torna all'inizio della Pagina

andrea 104KG
Utente Master


Marche


8769 Messaggi

Inserito il - 30/07/2019 : 13:49:36  Mostra Profilo Invia a andrea 104KG un Messaggio Privato  Rispondi Quotando
Grazie chri, non mi da molta fiducia forare è quasi impossibile non toccare il perno quadro che una volta danneggiato la pedivella non sta più ferma....
Mspider e marcoq, mi sembrate degli alieni, beati voi che capite quei codici....
Torna all'inizio della Pagina

Chri27.5
Utente Medio



426 Messaggi

Inserito il - 30/07/2019 : 14:47:20  Mostra Profilo  Rispondi Quotando
andrea 104KG ha scritto:

Grazie chri, non mi da molta fiducia forare è quasi impossibile non toccare il perno quadro che una volta danneggiato la pedivella non sta più ferma....
Mspider e marcoq, mi sembrate degli alieni, beati voi che capite quei codici....

Andrea,
Il perno quadro è temperato per cui con la punta per il ferro ci fai "rosine".
Fora e non preoccuparti, quando arrivi al perno ti occorgi immediatamente

Modificato da - Chri27.5 in data 30/07/2019 14:50:40
Torna all'inizio della Pagina

bob125
Utente Normale



53 Messaggi

Inserito il - 30/07/2019 : 16:44:14  Mostra Profilo  Rispondi Quotando
ciao, scusa, ma lo shimano non è tanto rumoroso? di più del nostro? 3 livelli non sono pochi?
il brose nuovo mura sempre?
Chri27.5 ha scritto:

Oggi ho provato un po' di bici tutte top di gamma elettriche, solo Shimano supera il nostro Tsdz2, dobbiamo convincere Marcoq a migliorare la coppia in basso questo mancherebbe per avere il top.
Buona serata a tutti voi

Torna all'inizio della Pagina

bob125
Utente Normale



53 Messaggi

Inserito il - 30/07/2019 : 16:54:28  Mostra Profilo  Rispondi Quotando
ciao,
nella mia chiavetta( appena arrivata, mi hanno fornito anche 4 cavetti, e mi chiedevo se devo attaccarli nella fila sopra o sotto della chiavetta??
mbrusa ha scritto:

Rotolo ha scritto:

@mbrusa, intendi questo come cavetto sensore velocità? http://www.pswpower.com/ven.php?cargo.2016-5n-qtqt
Per le saldature non ho problemi, per lavoro ho mi capita spesso di aggiornare firmware su apparecchiature che uso, solo che sono predisposte con cavetti dedicati e firmware non open, la cosa è molto più semplice e sicura, in questo caso visto che devo adattare il tutto, non volevo fare cavolate e rimanere a piedi.
Cosa intendi per cavetto da pc in disuso?

Si quello ho ordinato
Per il cavo PC, è un cavo con connettore piatto 5+5pin, provo ad allegare una foto

Immagine:

1456,62 KB
Torna all'inizio della Pagina

bob125
Utente Normale



53 Messaggi

Inserito il - 30/07/2019 : 16:59:10  Mostra Profilo  Rispondi Quotando
scusa chri, ma cosa vuol dire clicco su java?...sul mio pc è installato java, ma non posso cliccarci sopra!
Chri27.5 ha scritto:

bik3r ha scritto:

Anch'io sono in procinto di programmare, ho già il programmatore con il cavo ed ho installato i vari software, però prima di cominciare volevo dei chiarimenti su alcuni punti:

- faccio il backup del firmware originale (3 tab) con selezionato STM8S105X4 in tre file distinti, dopo devo cambiare il device con STM8S105X6 o con il software di MarcoQ fa tutto da solo?
- Se una volta caricato il nuovo firmware di MarcoQ volessi tornare al firmware originale devo selezionare STM8S105X4 giusto? O non è più possibile?
- Nel configuratore Java di MarcoQ vedo che i settaggi sono per il display VLCD6, che rispetto al VLCD5 ha un tasto in meno; una volta installato il firmware, tutti i tasti del VLCD5 sono corretti, cioè Walk assist e accensione fari sono sui relativi tasti?
- Con il menu di configurazione sul VLCD5 si può ancora cambiare qualche parametro, esempio diamatro ruota e limite velocità o bisogna passare per forza dal configuratore?
questo è il menù


- Ultima domanda è possibile che a ogni accensione parta il normal mode (legal) e se voglio attivo il boost (offroad mode) solo se mi serve?

Grazie a chiunque voglia rispondermi e mi scuso se ho detto delle banalità, ma prima di cominciare vorrei essere preparato per eventuali errori.

Ciao,
Allora per prima cosa devi installare sul PC i tre programmi,poi scarica la realaise di marcoq.
Apri visual st in configurazione 105X4 e salvi i tre file distinti in formato hex.
Poi apri la realise che hai scaricato ovviamente e zippata estrai i file dove vuoi, dopo apri la cartella e doppio click su Java,si apre il configuratore dove puoi cambiare e settare a tuo piacimento.
Ti consiglio di usare i parametri di default per prima poi quando prendi dimestichezza col tutto potrai cambiare quello che vuoi.
Cmq leggetevi tutto dall'inizio che trovate le risposte.
Per tornare indietro e semplice si usa solo visual st.
Torna all'inizio della Pagina

thineight
Utente Medio


Veneto


323 Messaggi

Inserito il - 30/07/2019 : 18:08:08  Mostra Profilo  Rispondi Quotando
Chri27.5, ho visto che stai sondando su endless-sphere se hanno avuto problemi di motore che non si stoppa.. forse conviene fargli notare quella faccenda dei bit di cui si parla qua sopra (mspider-marcoq)?
Oppure è solo una incongruenza nelle aggiunte apportate da marcoq?

MTB KTM Ultra 29" (TSDZ2 36V open source firmware v.0.20 beta1)
City bike DAYTONA 28" (TSDZ2 36V open source firmware mb.20beta1.A per VLCD5-VLCD6-XH18)
Torna all'inizio della Pagina

marcoq
Utente Medio



258 Messaggi

Inserito il - 30/07/2019 : 19:08:56  Mostra Profilo  Rispondi Quotando
thineight ha scritto:

Chri27.5, ho visto che stai sondando su endless-sphere se hanno avuto problemi di motore che non si stoppa.. forse conviene fargli notare quella faccenda dei bit di cui si parla qua sopra (mspider-marcoq)?
Oppure è solo una incongruenza nelle aggiunte apportate da marcoq?


Dovrebbe essere un mio errore... perchè la lunghezza del buffer per l'LCD3 è completamente diversa... questa parte l'avevo adattata per gli OEM.... comunque ci sto già lavorando!

Modificato da - marcoq in data 30/07/2019 19:10:30
Torna all'inizio della Pagina

Mauri78
Utente Medio


Piemonte


483 Messaggi

Inserito il - 30/07/2019 : 20:12:20  Mostra Profilo Invia a Mauri78 un Messaggio Privato  Rispondi Quotando
Scusate la domanda ma perchè per backuppare il fw originale devo selezionare il device 105X4? Io l'ho backuppata selezionendo l'X6 e non mi sembra di aver avuto problemi.... Ho provato anche a riflasharla e mi sembrava che tutto fosse ok....
Torna all'inizio della Pagina

Chri27.5
Utente Medio



426 Messaggi

Inserito il - 30/07/2019 : 20:43:05  Mostra Profilo  Rispondi Quotando
bob125 ha scritto:

scusa chri, ma cosa vuol dire clicco su java?...sul mio pc è installato java, ma non posso cliccarci sopra!
Chri27.5 ha scritto:

bik3r ha scritto:

Anch'io sono in procinto di programmare, ho già il programmatore con il cavo ed ho installato i vari software, però prima di cominciare volevo dei chiarimenti su alcuni punti:

- faccio il backup del firmware originale (3 tab) con selezionato STM8S105X4 in tre file distinti, dopo devo cambiare il device con STM8S105X6 o con il software di MarcoQ fa tutto da solo?
- Se una volta caricato il nuovo firmware di MarcoQ volessi tornare al firmware originale devo selezionare STM8S105X4 giusto? O non è più possibile?
- Nel configuratore Java di MarcoQ vedo che i settaggi sono per il display VLCD6, che rispetto al VLCD5 ha un tasto in meno; una volta installato il firmware, tutti i tasti del VLCD5 sono corretti, cioè Walk assist e accensione fari sono sui relativi tasti?
- Con il menu di configurazione sul VLCD5 si può ancora cambiare qualche parametro, esempio diamatro ruota e limite velocità o bisogna passare per forza dal configuratore?
questo è il menù


- Ultima domanda è possibile che a ogni accensione parta il normal mode (legal) e se voglio attivo il boost (offroad mode) solo se mi serve?

Grazie a chiunque voglia rispondermi e mi scuso se ho detto delle banalità, ma prima di cominciare vorrei essere preparato per eventuali errori.

Ciao,
Allora per prima cosa devi installare sul PC i tre programmi,poi scarica la realaise di marcoq.
Apri visual st in configurazione 105X4 e salvi i tre file distinti in formato hex.
Poi apri la realise che hai scaricato ovviamente e zippata estrai i file dove vuoi, dopo apri la cartella e doppio click su Java,si apre il configuratore dove puoi cambiare e settare a tuo piacimento.
Ti consiglio di usare i parametri di default per prima poi quando prendi dimestichezza col tutto potrai cambiare quello che vuoi.
Cmq leggetevi tutto dall'inizio che trovate le risposte.
Per tornare indietro e semplice si usa solo visual st.


Allora,
se hai installato, Java- st visual- sdcc procedi in questo modo:
1)scarica il file zip di marcoq con l'ultima versione
2) decomprimi la cartelle dove meglio credi
3)aprila e fai doppi clic su TSDZ2_configurator_v0.19......
4)si apre la schermata java che ha creato marcoq dove potrai modificare e riprogrammare i dati.
Torna all'inizio della Pagina

Chri27.5
Utente Medio



426 Messaggi

Inserito il - 30/07/2019 : 21:39:03  Mostra Profilo  Rispondi Quotando
thineight ha scritto:

Chri27.5, ho visto che stai sondando su endless-sphere se hanno avuto problemi di motore che non si stoppa.. forse conviene fargli notare quella faccenda dei bit di cui si parla qua sopra (mspider-marcoq)?
Oppure è solo una incongruenza nelle aggiunte apportate da marcoq?

Ciao thineight,
secondo me serve mettere un po di tranquillità su endless, stanno discutendo da un po sul sensore di sforzo, casainho e buba sono in disaccordo sulla versione 2,0 di come deve funzionare sto benedetto sensore, la mia personalissima opinione è appoggiare tutti noi buba, se siete d'accordo per il lavoro che ha fatto sulla 2,0, cosi finalmente rilascia sta versione è testiamo le molte migliorie che ha implementato e spiegato.
E grazie agli sviluppatori che siamo arrivati a questo livello sul tsdz2, andrebbe valorizzato il suo lavoro e non contestato,hanno entrambi ragione per i motivi che spiegavano sia casainho che buba, ma cosi non si arriva a nulla.
Cosa ne pensate?????

Modificato da - Chri27.5 in data 30/07/2019 22:10:26
Torna all'inizio della Pagina

bob125
Utente Normale



53 Messaggi

Inserito il - 30/07/2019 : 22:34:08  Mostra Profilo  Rispondi Quotando
io l'ho installato in c:/programmi(x86)...è un problema?
basta che cambio la directory nel configuratore, o no?

mbrusa ha scritto:

Ok
SDCC Compiler io ho installato questo
https://sourceforge.net/projects/sdcc/files/sdcc-win64/3.8.0/
ora ho visto che c'è anche la 3.9.0

Java Runtime
https://www.java.com/it/download/win10.jsp

Attenzione, ST Visual Programmer va installato in "C:/", NON in "C:/Programmi (x86)/"
Torna all'inizio della Pagina

marcoq
Utente Medio



258 Messaggi

Inserito il - 30/07/2019 : 22:47:01  Mostra Profilo  Rispondi Quotando
Ciao a tutti.
Ho terminato da poco i test del nuovo firmware M0.19.C.
Ho risolto il bug indicatomi da mspider65... inoltre ho ottimizzato il codice in vari punti del programma.
FORSE... e sottolineo FORSE... questo bug poteva corrompere alcune variabili in RAM e generare funzionamenti "inattesi"... ma solo il tempo e le vostre prove potranno confermarlo o meno.
Il configuratore java non ha subito modifiche quindi è rimasto alla versione 0.3.7.
Ho voluto rilasciare il prima possibile questo aggiornamento perché ad Agosto sarò abbastanza "Latitante"... spero per tutti voi che possiate andare in ferie con la vostra ebike con un firmware "Stabile"!
Una domanda.... qualcuno mi sa dire se il Throttle funziona?... perchè io non mai avuto modo di testarlo! Grazie!

Allegato: TSDZ2_Controller_vM0.19.C_and_TSDZ2_Configurator_0.3.7_con_codice_0.19_Stable.zip
4864,16 KB

Modificato da - marcoq in data 30/07/2019 22:57:09
Torna all'inizio della Pagina

andrea 104KG
Utente Master


Marche


8769 Messaggi

Inserito il - 30/07/2019 : 23:07:35  Mostra Profilo Invia a andrea 104KG un Messaggio Privato  Rispondi Quotando
chri, è vero buba va rispettato, ma casainho è un caratterino. Secondo me ha concepito il firmware principalmente per le sue esigenze e non tollera che vengano cambiate
Anche buba però credo che stravolga troppo le versioni, mi pare di aver letto che ha riscritto 3000 righe di codice! così è difficile venirne fuori tocca ritestare tutto, secondo me anche quando rilascerà la nuova versione avremo un sacco di bug
Personalmente avrei lasciato perdere la versione "double cadency" che non mi è chiaro se trasformerà il tsdz2 in un bbs, ignorando il sensore di sforzo penso proprio di si! Insomma se si voleva un pas si prendeva un bbs...
Torna all'inizio della Pagina

thineight
Utente Medio


Veneto


323 Messaggi

Inserito il - 30/07/2019 : 23:27:54  Mostra Profilo  Rispondi Quotando
Si, concordo che Buba vada assolutamente "difeso e assecondato" perché ha raggiunto un tale livello di conoscenza su questo progetto e riesce a sistemare bug e implementare nuove funzioni in veramente poco tempo, nonché con gentilezza estrema ascolta tutti i consigli. In parole povere... Si fa un bel mazzo! secondo me bisogna assolutamente evitare che arrivi ad un punto in cui si stufa e tira i remi in barca (come successe a Endlesscadence, l'altro sviluppatore che latita da mesi...)

PS: grazie Marco per l'update, anche tu sei ovviamente nell'olimpo degli sviluppatori

MTB KTM Ultra 29" (TSDZ2 36V open source firmware v.0.20 beta1)
City bike DAYTONA 28" (TSDZ2 36V open source firmware mb.20beta1.A per VLCD5-VLCD6-XH18)

Modificato da - thineight in data 30/07/2019 23:31:55
Torna all'inizio della Pagina

Chri27.5
Utente Medio



426 Messaggi

Inserito il - 30/07/2019 : 23:45:19  Mostra Profilo  Rispondi Quotando
Ok,
Uno per volta su endless incoraggiamo buba, così il suo morale si alza.
Incomincio io.

Concordo pienamente con microchip su marcoq, il suo lavoro ha permesso ha tutti noi di adattarci una gestione del motore personalizzata come nessuno mai su endless ha fatto.
Grazie Marcoq, puoi contare su di me per qualsiasi test ha bisogno.
Torna all'inizio della Pagina

Chri27.5
Utente Medio



426 Messaggi

Inserito il - 31/07/2019 : 00:20:21  Mostra Profilo  Rispondi Quotando
Scusatemi,
concordavo con thineight, mi ero confuso con microchip.
Torna all'inizio della Pagina

andrea 104KG
Utente Master


Marche


8769 Messaggi

Inserito il - 31/07/2019 : 18:47:17  Mostra Profilo Invia a andrea 104KG un Messaggio Privato  Rispondi Quotando
Uff... proma rottura del tsdz2... partita ruota libera csk 30p
Credevo ci volesse la pressa ma è uscita con semplici colpetti sulla morsa, proprio roba cinese...
Ordinata su cuscinetti.com qualcuno conosce la serietà del sito? Speriamo la consegna sia veloce come promettono... (24 ore sarà...)
Torna all'inizio della Pagina

andrea 104KG
Utente Master


Marche


8769 Messaggi

Inserito il - 31/07/2019 : 18:55:34  Mostra Profilo Invia a andrea 104KG un Messaggio Privato  Rispondi Quotando
Per la verità ho provato a farne una delle mie... ho saldato il cuscinetto in modo da trasformarlo in motore senza ruota libera. Però la saldatura ha leggermente distorto la posizione centrata del cuscinetto e dopo mezzo giro si bloccava l'accoppiamento con l'ingranaggio di trasmissione. Ovviamente non ho forzato perche si rompe subito l'alberino. Speriamo non sia la prima di una serie di rotture a catena... quando comincia qualcosa....
Torna all'inizio della Pagina

microchip
Utente Attivo


Veneto


756 Messaggi

Inserito il - 31/07/2019 : 20:05:11  Mostra Profilo Invia a microchip un Messaggio Privato  Rispondi Quotando
Ci mancava la saldatura sul tuo motore

Roberto
Torna all'inizio della Pagina
Pagina: di 74 Discussione Precedente Discussione Discussione Successiva  
Pagina Precedente | Pagina Successiva
 Nuova Discussione  Rispondi
 Versione Stampabile Bookmark this Topic Aggiungi Segnalibro
Vai a:
Forum Indipendente Biciclette Elettriche, Pieghevoli e Utility © 2000-06 jobike Torna all'inizio della Pagina
Questa pagina è stata generata in 0,89 secondi. Versione 3.4.06 by Modifichicci - Herniasurgery.it | Distribuito Da: Massimo Farieri - www.superdeejay.net | Powered By: Platinum Full - Snitz Forums 2000 Version 3.4.06
Creative Commons License
Questo/a opera è pubblicato sotto una Licenza Creative Commons.